<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Baudax Bio Inc. (BXRX) is on the roll with an average volume of 5.17M in the recent 3 months | Invest Chronicle</title>
    <meta charset="UTF-8"/>
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://investchronicle.com/xmlrpc.php"/>
    <meta name='robots' content='max-image-preview:large'/>
<meta property="og:image" content="https://investchronicle.com/wp-content/uploads/2019/06/investchronicle-92-e1579508192885.png"/><link rel="icon" type="image/png" href="https://investchronicle.com/wp-content/uploads/2020/05/Screenshot-2020-05-06-at-12.31.27-PM.png"><link rel='dns-prefetch' href='//fonts.googleapis.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="Invest Chronicle &raquo; Feed" href="https://investchronicle.com/feed/"/>
<link rel="alternate" type="application/rss+xml" title="Invest Chronicle &raquo; Comments Feed" href="https://investchronicle.com/comments/feed/"/>
<link rel="alternate" type="application/rss+xml" title="Invest Chronicle &raquo; Baudax Bio Inc. (BXRX) is on the roll with an average volume of 5.17M in the recent 3 months Comments Feed" href="https://investchronicle.com/2021/04/16/baudax-bio-inc-bxrx-is-on-the-roll-with-an-average-volume-of-5-17m-in-the-recent-3-months/feed/"/>
		<script type="text/javascript">window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/investchronicle.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.1"}};!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);</script>
		<script>function cpLoadCSS(e,t,n){"use strict";var i=window.document.createElement("link"),o=t||window.document.getElementsByTagName("script")[0];return i.rel="stylesheet",i.href=e,i.media="only x",o.parentNode.insertBefore(i,o),setTimeout(function(){i.media=n||"all"}),i}</script><style>.cp-popup-container .cpro-overlay,.cp-popup-container .cp-popup-wrapper{opacity:0;visibility:hidden;display:none}</style><!-- investchronicle.com is managing ads with Advanced Ads --><script>advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();</script>
		<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-.1em!important;background:none!important;padding:0!important}</style>
	<link rel='stylesheet' id='wp-block-library-css' href='https://investchronicle.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.1' type='text/css' media='all'/>
<script>document.addEventListener('DOMContentLoaded',function(event){if(typeof cpLoadCSS!=='undefined'){cpLoadCSS('https://investchronicle.com/wp-content/plugins/convertpro/assets/modules/css/cp-popup.min.css?ver=1.5.7',0,'all');}});</script>
<link rel='stylesheet' id='td-plugin-multi-purpose-css' href='https://investchronicle.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=61179afdbbd6a8d8c8a7f82ae3fcd87d' type='text/css' media='all'/>
<link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Merriweather+Sans%3A400%2C700%2C800%7COpen+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%2C800%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900%2C800&#038;ver=9.7.3' type='text/css' media='all'/>
<link rel='stylesheet' id='td-theme-css' href='https://investchronicle.com/wp-content/themes/Newspaper/style.css?ver=9.7.3' type='text/css' media='all'/>
<style id='td-theme-inline-css' type='text/css'>@media (max-width:767px){.td-header-desktop-wrap{display:none}}@media (min-width:767px){.td-header-mobile-wrap{display:none}}</style>
<link rel='stylesheet' id='td-legacy-framework-front-style-css' href='https://investchronicle.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css,qver=61179afdbbd6a8d8c8a7f82ae3fcd87d.pagespeed.ce.pEIxYeMPE_.css' type='text/css' media='all'/>
<link rel='stylesheet' id='td-theme-demo-style-css' href='https://investchronicle.com/wp-content/plugins/td-composer/legacy/Newspaper/includes/demos/business/demo_style.css?ver=9.7.3' type='text/css' media='all'/>
<link rel='stylesheet' id='tdb_front_style-css' href='https://investchronicle.com/wp-content/plugins/td-cloud-library/assets/css/tdb_less_front.css?ver=d158fac1e2f85794ec26781eb2a38fd9' type='text/css' media='all'/>
<script type='text/javascript' src='https://investchronicle.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://investchronicle.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://investchronicle.com/wp-json/"/><link rel="alternate" type="application/json" href="https://investchronicle.com/wp-json/wp/v2/posts/159911"/><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://investchronicle.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://investchronicle.com/wp-includes/wlwmanifest.xml"/> 
<meta name="generator" content="WordPress 5.7.1"/>
<link rel="canonical" href="https://investchronicle.com/2021/04/16/baudax-bio-inc-bxrx-is-on-the-roll-with-an-average-volume-of-5-17m-in-the-recent-3-months/"/>
<link rel='shortlink' href='https://investchronicle.com/?p=159911'/>
<link rel="alternate" type="application/json+oembed" href="https://investchronicle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Finvestchronicle.com%2F2021%2F04%2F16%2Fbaudax-bio-inc-bxrx-is-on-the-roll-with-an-average-volume-of-5-17m-in-the-recent-3-months%2F"/>
<link rel="alternate" type="text/xml+oembed" href="https://investchronicle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Finvestchronicle.com%2F2021%2F04%2F16%2Fbaudax-bio-inc-bxrx-is-on-the-roll-with-an-average-volume-of-5-17m-in-the-recent-3-months%2F&#038;format=xml"/>
<script type="text/javascript">(function(){window.advBidxc=window.advBidxc||{};window.advBidxc.startTime=new Date().getTime();function loadScript(tagSrc){var scriptTag=document.createElement('script'),placeTag=document.getElementsByTagName("script")[0];scriptTag.type='text/javascript';scriptTag.async=true;scriptTag.src=tagSrc;placeTag.parentNode.insertBefore(scriptTag,placeTag);}var mnSrc='//hbx.media.net/bidexchange.js?cid=8CU2C156D&version=5.1'+'&dn='+window.location.hostname;loadScript(mnSrc);})();</script><!-- Snippets by Add to All --><!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
        <script>window.tdb_globals={"wpRestNonce":"48c2136934","wpRestUrl":"https:\/\/investchronicle.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"origPostEditUrl":null};</script>
    			<script>window.tdwGlobal={"adminUrl":"https:\/\/investchronicle.com\/wp-admin\/","wpRestNonce":"48c2136934","wpRestUrl":"https:\/\/investchronicle.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/"};</script>
			<style type="text/css">.recentcomments a{display:inline!important;padding:0!important;margin:0!important}</style>
<!-- JS generated by theme -->

<script>var tdBlocksArray=[];function tdBlock(){this.id='';this.block_type=1;this.atts='';this.td_column_number='';this.td_current_page=1;this.post_count=0;this.found_posts=0;this.max_num_pages=0;this.td_filter_value='';this.is_ajax_running=false;this.td_user_action='';this.header_color='';this.ajax_pagination_infinite_stop='';}(function(){var htmlTag=document.getElementsByTagName("html")[0];if(navigator.userAgent.indexOf("MSIE 10.0")>-1){htmlTag.className+=' ie10';}if(!!navigator.userAgent.match(/Trident.*rv\:11\./)){htmlTag.className+=' ie11';}if(navigator.userAgent.indexOf("Edge")>-1){htmlTag.className+=' ieEdge';}if(/(iPad|iPhone|iPod)/g.test(navigator.userAgent)){htmlTag.className+=' td-md-is-ios';}var user_agent=navigator.userAgent.toLowerCase();if(user_agent.indexOf("android")>-1){htmlTag.className+=' td-md-is-android';}if(-1!==navigator.userAgent.indexOf('Mac OS X')){htmlTag.className+=' td-md-is-os-x';}if(/chrom(e|ium)/.test(navigator.userAgent.toLowerCase())){htmlTag.className+=' td-md-is-chrome';}if(-1!==navigator.userAgent.indexOf('Firefox')){htmlTag.className+=' td-md-is-firefox';}if(-1!==navigator.userAgent.indexOf('Safari')&&-1===navigator.userAgent.indexOf('Chrome')){htmlTag.className+=' td-md-is-safari';}if(-1!==navigator.userAgent.indexOf('IEMobile')){htmlTag.className+=' td-md-is-iemobile';}})();var tdLocalCache={};(function(){"use strict";tdLocalCache={data:{},remove:function(resource_id){delete tdLocalCache.data[resource_id];},exist:function(resource_id){return tdLocalCache.data.hasOwnProperty(resource_id)&&tdLocalCache.data[resource_id]!==null;},get:function(resource_id){return tdLocalCache.data[resource_id];},set:function(resource_id,cachedData){tdLocalCache.remove(resource_id);tdLocalCache.data[resource_id]=cachedData;}};})();var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];var tdc_is_installed="yes";var td_ajax_url="https:\/\/investchronicle.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=9.7.3";var td_get_template_directory_uri="https:\/\/investchronicle.com\/wp-content\/plugins\/td-composer\/legacy\/common";var tds_snap_menu="";var tds_logo_on_sticky="";var tds_header_style="";var td_please_wait="Please wait...";var td_email_user_pass_incorrect="User or password incorrect!";var td_email_user_incorrect="Email or username incorrect!";var td_email_incorrect="Email incorrect!";var tds_more_articles_on_post_enable="";var tds_more_articles_on_post_time_to_wait="";var tds_more_articles_on_post_pages_distance_from_top=0;var tds_theme_color_site_wide="#005689";var tds_smart_sidebar="enabled";var tdThemeName="Newspaper";var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";var td_magnific_popup_translation_tNext="Next (Right arrow key)";var td_magnific_popup_translation_tCounter="%curr% of %total%";var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";var tdBlockNonce="73d7550024";var tdsDateFormat="l, F j, Y";var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};var td_ad_background_click_link="";var td_ad_background_click_target="";</script>


<!-- Header style compiled by theme -->

<style>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</style>

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-142868351-1"></script>
<script>window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments);}gtag('js',new Date());gtag('config','UA-142868351-1');</script>



<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://investchronicle.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://investchronicle.com/category/news/",
                    "name": "News"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://investchronicle.com/2021/04/16/baudax-bio-inc-bxrx-is-on-the-roll-with-an-average-volume-of-5-17m-in-the-recent-3-months/",
                    "name": "Baudax Bio Inc. (BXRX) is on the roll with an average volume..."                                
                }
            }    
        ]
    }
</script>
				<!-- This is google analytics tracking code added by Convert Pro -->
				<script type="text/javascript">(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');ga('create','UA-142868351-1','auto');ga('set','anonymizeIp',true);ga('send','pageview');</script>
				<!-- End of google analytics tracking code added by Convert Pro -->
				
<!-- Button style compiled by theme -->

<style>.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>.current-category-ancestor>a,.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>.current-menu-ancestor>a,.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>.current-menu-item>a,.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>.sfHover>a,.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>li>a:hover,.tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,.tds-button2 .tdm-btn-text,.tds-button2 i,.tds-button5:hover .tdm-btn-text,.tds-button5:hover i,.tds-button6 .tdm-btn-text,.tds-button6 i,.tdm_block_list .tdm-list-item i,.tdm_block_pricing .tdm-pricing-feature i,.tdm-social-item i{color:#005689}.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu>.current-menu-item>a,.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu>.current-menu-ancestor>a,.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu>.current-category-ancestor>a,.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu>li>a:hover,.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu>.sfHover>a,.tds-button1,.tds-button6:after,.tds-title2 .tdm-title-line:after,.tds-title3 .tdm-title-line:after,.tdm_block_pricing.tdm-pricing-featured:before,.tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,.tds-progress-bar1 .tdm-progress-bar:after,.tds-progress-bar2 .tdm-progress-bar:after,.tds-social3 .tdm-social-item{background-color:#005689}.tdm-menu-active-style4 .tdm-header .sf-menu>.current-menu-item>a,.tdm-menu-active-style4 .tdm-header .sf-menu>.current-menu-ancestor>a,.tdm-menu-active-style4 .tdm-header .sf-menu>.current-category-ancestor>a,.tdm-menu-active-style4 .tdm-header .sf-menu>li>a:hover,.tdm-menu-active-style4 .tdm-header .sf-menu>.sfHover>a,.tds-button2:before,.tds-button6:before,.tds-progress-bar3 .tdm-progress-bar:after{border-color:#005689}.tdm-btn-style1{background-color:#005689}.tdm-btn-style2:before{border-color:#005689}.tdm-btn-style2{color:#005689}.tdm-btn-style3{-webkit-box-shadow:0 2px 16px #005689;-moz-box-shadow:0 2px 16px #005689;box-shadow:0 2px 16px #005689}.tdm-btn-style3:hover{-webkit-box-shadow:0 4px 26px #005689;-moz-box-shadow:0 4px 26px #005689;box-shadow:0 4px 26px #005689}.tdm-header-style-1.td-header-wrap .td-header-top-menu-full,.tdm-header-style-1.td-header-wrap .top-header-menu .sub-menu,.tdm-header-style-2.td-header-wrap .td-header-top-menu-full,.tdm-header-style-2.td-header-wrap .top-header-menu .sub-menu,.tdm-header-style-3.td-header-wrap .td-header-top-menu-full,.tdm-header-style-3.td-header-wrap .top-header-menu .sub-menu{background-color:#005689}.tdm-menu-active-style2 .tdm-header ul.sf-menu>.td-menu-item,.tdm-menu-active-style4 .tdm-header ul.sf-menu>.td-menu-item,.tdm-header .tdm-header-menu-btns,.tdm-header-style-1 .td-main-menu-logo a,.tdm-header-style-2 .td-main-menu-logo a,.tdm-header-style-3 .td-main-menu-logo a{line-height:36px}.tdm-header-style-1 .td-main-menu-logo,.tdm-header-style-2 .td-main-menu-logo,.tdm-header-style-3 .td-main-menu-logo{height:36px}@media (min-width:767px){.tdm-header-style-1 .td-main-menu-logo img,.tdm-header-style-2 .td-main-menu-logo img,.tdm-header-style-3 .td-main-menu-logo img{max-height:36px}}</style>

	<style id="tdw-css-placeholder"></style></head>

<body class="post-template-default single single-post postid-159911 single-format-standard baudax-bio-inc-bxrx-is-on-the-roll-with-an-average-volume-of-5-17m-in-the-recent-3-months global-block-template-11 td-business aa-prefix-inves- td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Linkedin">
                <i class="td-icon-font td-icon-linkedin"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="RSS">
                <i class="td-icon-font td-icon-rss"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Yahoo">
                <i class="td-icon-font td-icon-yahoo"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-top-container"><ul id="menu-top" class="td-mobile-main-menu"><li id="menu-item-1104" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first menu-item-1104"><a href="https://investchronicle.com/">Home</a></li>
<li id="menu-item-129247" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-129247"><a href="https://investchronicle.com/category/stock-investing/">Stock Investing</a></li>
<li id="menu-item-129248" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-129248"><a href="https://investchronicle.com/category/market-activity/">Market Activity</a></li>
<li id="menu-item-129249" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-129249"><a href="https://investchronicle.com/category/equity-news/">Equity News</a></li>
<li id="menu-item-129250" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-129250"><a href="https://investchronicle.com/category/trading-signals/">Trading Signals</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://investchronicle.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off"/>
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>

    <div id="td-outer-wrap" class="td-theme-wrap">
    
        
            <div class="tdc-header-wrap ">

            <!--
Header style 1
-->


<div class="td-header-wrap td-header-style-1 ">
    
    <div class="td-header-top-menu-full td-container-wrap ">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div style="visibility:hidden;">

                Friday, April 16, 2021
            </div>
        </div>
    </div>
        <div class="td-header-sp-top-widget">
    
    </div>    </div>

<!-- LOGIN MODAL -->
        </div>
    </div>

    <div class="td-banner-wrap-full td-logo-wrap-full td-container-wrap ">
        <div class="td-container td-header-row td-header-header">
            <div class="td-header-sp-logo">
                        <a class="td-main-logo" href="https://investchronicle.com/">
            <img class="td-retina-data" data-retina="https://investchronicle.com/wp-content/uploads/2020/05/Investchronicle-logo-300x74.png" src="https://investchronicle.com/wp-content/uploads/2020/05/Investchronicle-logo-300x74.png" alt=""/>
            <span class="td-visual-hidden">Invest Chronicle</span>
        </a>
                </div>
                            <div class="td-header-sp-recs">
                    <div class="td-header-rec-wrap">
    
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-header td_uid_1_607a00356b7b2_rand td_block_template_11 ">

<style>.td_uid_1_607a00356b7b2_rand.td-a-rec-img{text-align:left}.td_uid_1_607a00356b7b2_rand.td-a-rec-img img{margin:0 auto 0 0}</style><script type="text/javascript">var td_screen_width=window.innerWidth;if(td_screen_width>=1140){document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-4244787476385340" data-ad-slot="2370847351"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}if(td_screen_width>=1019&&td_screen_width<1140){document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-4244787476385340" data-ad-slot="2370847351"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}if(td_screen_width>=768&&td_screen_width<1019){document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-4244787476385340" data-ad-slot="2370847351"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}if(td_screen_width<768){document.write('<ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-4244787476385340" data-ad-slot="2370847351"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}</script>
</div>

 <!-- end A --> 


</div>                </div>
                    </div>
    </div>

    <div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap td-header-gradient ">
            <div class="td-container td-header-row td-header-main-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
        		<a class="td-mobile-logo td-sticky-disable" href="https://investchronicle.com/">
			<img class="td-retina-data" data-retina="https://investchronicle.com/wp-content/uploads/2020/05/Investchronicle-logo-300x74.png" src="https://investchronicle.com/wp-content/uploads/2020/05/Investchronicle-logo-300x74.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-disable" href="https://investchronicle.com/">
			<img class="td-retina-data" data-retina="https://investchronicle.com/wp-content/uploads/2020/05/Investchronicle-logo-300x74.png" src="https://investchronicle.com/wp-content/uploads/2020/05/Investchronicle-logo-300x74.png" alt=""/>
		</a>
	    </div>
    <div class="menu-top-container"><ul id="menu-top-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-1104"><a href="https://investchronicle.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-129247"><a href="https://investchronicle.com/category/stock-investing/">Stock Investing</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-129248"><a href="https://investchronicle.com/category/market-activity/">Market Activity</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-129249"><a href="https://investchronicle.com/category/equity-news/">Equity News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-129250"><a href="https://investchronicle.com/category/trading-signals/">Trading Signals</a></li>
</ul></div></div>


    <div class="header-search-wrap">
        <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            <a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>

        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://investchronicle.com/">
                <div role="search" class="td-head-form-search-wrap">
                    <input id="td-header-search" type="text" value="" name="s" autocomplete="off"/><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search"/>
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    </div>
            </div>
        </div>
    </div>

</div>
            </div>

            
    <div class="td-main-content-wrap td-container-wrap">

        <div class="td-container td-post-template-default ">
            <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://investchronicle.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in News" class="entry-crumb" href="https://investchronicle.com/category/news/">News</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Baudax Bio Inc. (BXRX) is on the roll with an average volume...</span></div></div>

            <div class="td-pb-row">
                                        <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-159911" class="post-159911 post type-post status-publish format-standard has-post-thumbnail category-news tag-bxrx tag-baudax-bio-inc tag-baudax-bio-inc-nasdaqbxrx tag-bxrx-shares tag-bxrx-stock tag-nasdaqbxrx" itemscope itemtype="https://schema.org/Article" 47>
        <div class="td-post-header">

            <!-- category --><ul class="td-category"><li class="entry-category"><a href="https://investchronicle.com/category/news/">News</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">Baudax Bio Inc. (BXRX) is on the roll with an average volume of 5.17M in the recent 3 months</h1>
                

                <div class="td-module-meta-info">
                    <!-- author --><div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://investchronicle.com/author/nick-little/">Nick Little</a><div class="td-author-line"> - </div> </div>                    <!-- date --><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-04-16T20:40:00+00:00">April 16, 2021</time></span>                    <!-- comments -->                    <!-- views -->                </div>

            </header>

        </div>

        
        <div class="td-post-content">
            <!-- image -->
            <!-- content --><div class="inves-before-content" style="margin-left: auto; margin-right: auto; text-align: center; " id="inves-384942947"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-4244787476385340" data-ad-slot="2370847351" data-ad-format="auto"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script>
</div><div class="inves-before-amp" id="inves-1411800604"><amp-ad width="100vw" height="320" type="adsense" data-ad-client="ca-pub-4244787476385340" data-ad-slot="5911116041" data-auto-format="rspv" data-full-width="">
  <div overflow=""></div>
</amp-ad></div><p>For the readers interested in the stock health of Baudax Bio Inc. (BXRX). It is currently valued at $1.02. When the transactions were called off in the previous session, Stock hit the highs of $1.19, after setting-off with the price of $1.19. Company’s stock value dipped to $1.06 during the trading on the day. When the trading was stopped its value was $1.06.</p>
<h3 style='text-align: center;'><span style='color: #0000ff;'><a style='color: #0000ff;' href='#' class='manual_trigger_126461'> Get the hottest stocks to trade every day before the market opens 100% free. Click here now. </a></span></h3>
<p>Recently in News on April 1, 2021, Baudax Bio Reports Inducement Grant Under Nasdaq Listing Rule 5635(c)(4). Baudax Bio, Inc. (Nasdaq: BXRX), a pharmaceutical company focused on therapeutics for acute care settings, today announced that the Compensation Committee of Baudax Bio’s Board of Directors approved an inducement grant of stock options to purchase an aggregate of 7,500 shares of Baudax Bio’s common stock and restricted stock units covering 2,000 shares of Baudax Bio’s common stock in connection with one newly-hired employee with a grant date of March 31, 2021. The equity award was granted pursuant to the Nasdaq Rule 5635(c)(4) inducement grant exception as a component of the individual’s employment compensation and was granted as an inducement material to his acceptance of employment with Baudax Bio. You can read further details <a href="https://finance.yahoo.com/news/baudax-bio-reports-inducement-grant-110000582.html">here</a></p><div class="inves-2nd-p-content" id="inves-1513704424"><hr/>
<p style=“text-align: left;“><a href=https://secure.verifiedlink.net/aff_c?offer_id=1491&aff_id=1775&file_id=4084target=“_blank”>A Backdoor Way To Profit From Today’s Crypto Bull Market
</a></p>
<p>
Even if you’re not actively in crypto, you deserve to know what’s actually going on...
<br><br>
Because while leading assets such as Bitcoin (BTC) and Ethereum (ETH) are climbing in value, a select group of public “crypto stocks” are surging right along with them. More importantly, these stocks are outpacing the returns these leading crypto assets aren already producing.


</p>
<p> <strong><a href=https://secure.verifiedlink.net/aff_c?offer_id=1491&aff_id=1775&file_id=4084target=“_blank”>Click here to get the full story</a>… along with our long list of backdoor Bitcoin strategies. It’s free.</strong>
.</p>
<p style=“font-size:10pt;line-height:150%“><span style=“color:#cccccc”>Sponsored</span></p>
<hr><img loading="lazy" src="https://secure.verifiedlink.net/aff_i?offer_id=1491&file_id=4084&aff_id=1775" width="0" height="0" style="position:absolute;visibility:hidden;" border="0"/></div><div class="inves-2nd-p-amp" id="inves-1723341574"><amp-ad width="100vw" height="320" type="adsense" data-ad-client="ca-pub-4244787476385340" data-ad-slot="5911116041" data-auto-format="rspv" data-full-width="">
  <div overflow=""></div>
</amp-ad></div>
<p>Baudax Bio Inc. had a pretty Dodgy run when it comes to the market performance. The 1-year high price for the company’s stock is recorded $2.1200 on 02/09/21, with the lowest value was $0.9850 for the same time period, recorded on 01/04/21.</p>
<h3>Baudax Bio Inc. (BXRX) full year performance was -55.65%</h3>
<p>Price records that include history of low and high prices in the period of 52 weeks can tell a lot about the stock’s existing status and the future performance. Presently, Baudax Bio Inc. shares are logging -79.39% during the 52-week period from high price, and 5.15% higher than the lowest price point for the same timeframe. The stock’s price range for the 52-week period managed to maintain the performance between $0.97 and $4.95.</p><div class="inves-4-p-amp" id="inves-336697030"><amp-ad width="100vw" height="320" type="adsense" data-ad-client="ca-pub-4244787476385340" data-ad-slot="5911116041" data-auto-format="rspv" data-full-width="">
  <div overflow=""></div>
</amp-ad></div>
<p>The company’s shares, operating in the sector of Healthcare managed to top a trading volume set approximately around 879915 for the day, which was evidently lower, when compared to the average daily volumes of the shares.</p><div class="inves-5-p-content" style="margin-left: auto; margin-right: auto; text-align: center; " id="inves-492822618"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-4244787476385340" data-ad-slot="2370847351" data-ad-format="auto"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script>
</div>
<p>When it comes to the year-to-date metrics, the Baudax Bio Inc. (BXRX) recorded performance in the market was 4.95%, having the revenues showcasing -19.70% on a quarterly basis in comparison with the same period year before. At the time of this writing, the total market value of the company is set at 79.46M, as it employees total of 57 workers.</p><div class="inves-6-p-amp" id="inves-315424154"><amp-ad width="100vw" height="320" type="adsense" data-ad-client="ca-pub-4244787476385340" data-ad-slot="5911116041" data-auto-format="rspv" data-full-width="">
  <div overflow=""></div>
</amp-ad></div>
<h3>Baudax Bio Inc. (BXRX) in the eye of market guru’s</h3>
<p>During the last month, 0 analysts gave the Baudax Bio Inc. a BUY rating, 0 of the polled analysts branded the stock as an OVERWEIGHT, 0 analysts were recommending to HOLD this stock, 0 of them gave the stock UNDERWEIGHT rating, and 0 of the polled analysts provided SELL rating.</p>
<p>According to the data provided on Barchart.com, the moving average of the company in the 100-day period was set at 1.3038, with a change in the price was noted -0.0200. In a similar fashion, Baudax Bio Inc. posted a movement of -1.90% for the period of last 100 days, recording 4,738,450 in trading volumes.</p>
<h3>Baudax Bio Inc. (BXRX): Stocks Technical analysis and Trends</h3>
<p>Raw Stochastic average of Baudax Bio Inc. in the period of last 50 days is set at 1.80%. The result represents downgrade in oppose to Raw Stochastic average for the period of the last 20 days, recording 3.51%. In the last 20 days, the company’s Stochastic %K was 7.00% and its Stochastic %D was recorded 8.35%.</p><div class="inves-2-p-bottom" id="inves-1136692005"><div id="io_15f35ff1be95cc"></div>
<script>var iO=["io_15f35ff1be95cc","1373","970","250","1"];</script>
<script src="//ioadserve.com/nSiteAds.js?show=1" type="text/javascript"></script>
<!-- End IO Disp_Ad -->
<style type="text/css">#io_15f35ff1be95cc{width:100%!important}.ioBlockAd table tr td:first-child{display:none}#io_15f35ff1be95cc_title{font-size:15px!important;color:#31d6aa!important;font-family:Verdana,Geneva,sans-serif!important;margin-bottom:35px}#io_15f35ff1be95cc_body{font-size:15px!important;line-height:1.74;font-family:Verdana,Geneva,sans-serif!important}#io_15f35ff1be95cc_button{background-color:transparent!important;color:#31d6aa!important;font-weight:bold;font-size:15px!important;font-family:Verdana,Geneva,sans-serif!important;padding-left:0!important}#io_15f35ff1be95cc img{display:none!important}</style></div>
<h3 style='text-align: center;'><span style='color: #0000ff;'><a style='color: #0000ff;' href='#' class='manual_trigger_126461'> Get the hottest stocks to trade every day before the market opens 100% free. Click here now. </a></span></h3>
<p>If we look into the earlier routines of Baudax Bio Inc., multiple moving trends are noted. Year-to-date Price performance of the company’s stock appears to be pessimistic, given the fact the metric is recording 4.95%. Additionally, trading for the stock in the period of the last six months notably deteriorated by -62.01%, alongside a downfall of -55.65% for the period of the last 12 months. The shares increased approximately by -15.20% in the 7-day charts and went up by -24.29% in the period of the last 30 days. Common stock shares were lifted by -19.70% during last recorded quarter.</p>
<span class="cp-load-after-post"></span><div class="inves-after-amp" id="inves-1758846033"><amp-ad width="100vw" height="320" type="adsense" data-ad-client="ca-pub-4244787476385340" data-ad-slot="5911116041" data-auto-format="rspv" data-full-width="">
  <div overflow=""></div>
</amp-ad></div><div class="inves-after-content_2" id="inves-2575118"><div id=InvestChronicle_ROS_Top_Leaderboard"></div>
</div><div class="inves-after-content" style="margin-left: auto; margin-right: auto; text-align: center; " id="inves-962407936"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-4244787476385340" data-ad-slot="2370847351" data-ad-format="auto"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script>
</div><div class="footer-post-form">
	<div class="footer-post-form-inner">
<h2>Get The Best Stocks To Trade Every Day!</h2>
<p>Join now to get the NewsHeater.com pre-market morning brief 100% free</p>
<form method="post" class="af-form-wrapper" accept-charset="UTF-8" action="https://www.aweber.com/scripts/addlead.pl">
<div style="display: none;">
<input type="hidden" name="meta_web_form_id" value="317242835"/>
<input type="hidden" name="meta_split_id" value=""/>
<input type="hidden" name="listname" value="awlist5641516"/>
<input type="hidden" name="redirect" value="https://offers.afteroffers.com/show_offers/568-RiAQXxc-1" id="redirect_18d71052ef474f7c0b4b401915053068"/>

<input type="hidden" name="meta_adtracking" value="My Web Form"/>
<input type="hidden" name="meta_message" value="1"/>
<input type="hidden" name="meta_required" value="email"/>
<input type="hidden" name="meta_forward_vars" value="1"/>
<input type="hidden" name="meta_tooltip" value=""/>
</div>
	<input class="text" id="awf_field-109620329" type="text" name="email" placeholder="Enter your email here" value="" tabindex="500" onfocus=" if (this.value == '') { this.value = ''; }" onblur="if (this.value == '') { this.value='';} "/>
<input name="submit" class="submit" type="submit" value="Submit" tabindex="501"/>

<div style="display: none;"><img src="https://forms.aweber.com/form/displays.htm?id=zIzsTCxMHMys" alt=""/></div>
</form>
<script type="text/javascript">(function(){function browserSupportsNewWindows(userAgent){var rules=['FBIOS','Twitter for iPhone','WebView','(iPhone|iPod|iPad)(?!.*Safari/)','Android.*(wv|.0.0.0)'];var pattern=new RegExp('('+rules.join('|')+')','ig');return!pattern.test(userAgent);}if(!browserSupportsNewWindows(navigator.userAgent||navigator.vendor||window.opera)){document.getElementById('af-form-317242835').parentElement.removeAttribute('target');}})();</script><script type="text/javascript">(function(){var IE=/*@cc_on!@*/false;if(!IE){return;}if(document.compatMode&&document.compatMode=='BackCompat'){if(document.getElementById("af-form-317242835")){document.getElementById("af-form-317242835").className='af-form af-quirksMode';}if(document.getElementById("af-body-317242835")){document.getElementById("af-body-317242835").className="af-body inline af-quirksMode";}if(document.getElementById("af-header-317242835")){document.getElementById("af-header-317242835").className="af-header af-quirksMode";}if(document.getElementById("af-footer-317242835")){document.getElementById("af-footer-317242835").className="af-footer af-quirksMode";}}})();</script>
</div>
</div>

<div id="InvestChronicle_ROS_Top_Leaderboard"></div>
        </div>

        <footer>
            <!-- post pagination -->            <!-- review -->
            <div class="td-post-source-tags">
                <!-- source via -->                <!-- tags --><ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://investchronicle.com/tag/bxrx/">(BXRX)</a></li><li><a href="https://investchronicle.com/tag/baudax-bio-inc/">Baudax Bio Inc.</a></li><li><a href="https://investchronicle.com/tag/baudax-bio-inc-nasdaqbxrx/">Baudax Bio Inc. (NASDAQ:BXRX)</a></li><li><a href="https://investchronicle.com/tag/bxrx-shares/">BXRX Shares</a></li><li><a href="https://investchronicle.com/tag/bxrx-stock/">BXRX Stock</a></li><li><a href="https://investchronicle.com/tag/nasdaqbxrx/">NASDAQ:BXRX</a></li></ul>            </div>

            <div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://investchronicle.com/2021/04/16/baudax-bio-inc-bxrx-is-on-the-roll-with-an-average-volume-of-5-17m-in-the-recent-3-months/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Finvestchronicle.com%2F2021%2F04%2F16%2Fbaudax-bio-inc-bxrx-is-on-the-roll-with-an-average-volume-of-5-17m-in-the-recent-3-months%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Baudax+Bio+Inc.+%28BXRX%29+is+on+the+roll+with+an+average+volume+of+5.17M+in+the+recent+3+months&url=https%3A%2F%2Finvestchronicle.com%2F2021%2F04%2F16%2Fbaudax-bio-inc-bxrx-is-on-the-roll-with-an-average-volume-of-5-17m-in-the-recent-3-months%2F&via=Invest+Chronicle">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://investchronicle.com/2021/04/16/baudax-bio-inc-bxrx-is-on-the-roll-with-an-average-volume-of-5-17m-in-the-recent-3-months/&amp;media=https://investchronicle.com/wp-content/uploads/2019/06/investchronicle-92-e1579508192885.png&description=Baudax+Bio+Inc.+%28BXRX%29+is+on+the+roll+with+an+average+volume+of+5.17M+in+the+recent+3+months">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Baudax+Bio+Inc.+%28BXRX%29+is+on+the+roll+with+an+average+volume+of+5.17M+in+the+recent+3+months %0A%0A https://investchronicle.com/2021/04/16/baudax-bio-inc-bxrx-is-on-the-roll-with-an-average-volume-of-5-17m-in-the-recent-3-months/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>            <!-- next prev --><div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://investchronicle.com/2021/04/16/gear-up-for-the-change-360-digitech-inc-qfin-has-hit-the-volume-of-898595/">Gear up for the change! 360 DigiTech Inc. (QFIN) has hit the volume of 898595</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://investchronicle.com/2021/04/16/accenture-plc-acn-is-on-the-roll-with-an-average-volume-of-2-14m-in-the-recent-3-months/">Accenture plc (ACN) is on the roll with an average volume of 2.14M in the recent 3 months</a></div></div></div>            <!-- author box --><div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://investchronicle.com/author/nick-little/">Nick Little</a></span></div>            <!-- meta --><span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Nick Little"></span><meta itemprop="datePublished" content="2021-04-16T20:40:00+00:00"><meta itemprop="dateModified" content="2021-04-16T20:40:00+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://investchronicle.com/2021/04/16/baudax-bio-inc-bxrx-is-on-the-roll-with-an-average-volume-of-5-17m-in-the-recent-3-months/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://investchronicle.com/wp-content/uploads/2020/05/Investchronicle-logo-300x74.png"></span><meta itemprop="name" content="Invest Chronicle"></span><meta itemprop="headline " content="Baudax Bio Inc. (BXRX) is on the roll with an average volume of 5.17M in the recent 3 months"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://investchronicle.com/wp-content/uploads/2019/06/investchronicle-92-e1579508192885.png"><meta itemprop="width" content="450"><meta itemprop="height" content="299"></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts td_uid_3_607a00356ff20_rand td_with_ajax_pagination td-pb-border-top td_block_template_11" data-td-block-uid="td_uid_3_607a00356ff20"><script>var block_td_uid_3_607a00356ff20=new tdBlock();block_td_uid_3_607a00356ff20.id="td_uid_3_607a00356ff20";block_td_uid_3_607a00356ff20.atts='{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"td_uid_3_607a00356ff20_rand","td_column_number":3,"live_filter_cur_post_id":159911,"live_filter_cur_post_author":"5","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"td_uid_3_607a00356ff20_rand","tdc_css_class_style":"td_uid_3_607a00356ff20_rand_style"}';block_td_uid_3_607a00356ff20.td_column_number="3";block_td_uid_3_607a00356ff20.block_type="td_block_related_posts";block_td_uid_3_607a00356ff20.post_count="3";block_td_uid_3_607a00356ff20.found_posts="3174";block_td_uid_3_607a00356ff20.header_color="";block_td_uid_3_607a00356ff20.ajax_pagination_infinite_stop="";block_td_uid_3_607a00356ff20.max_num_pages="1058";tdBlocksArray.push(block_td_uid_3_607a00356ff20);</script><h4 class="td-related-title td-block-title"><a id="td_uid_4_607a003578382" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_3_607a00356ff20" href="#">RELATED ARTICLES</a><a id="td_uid_5_607a003578388" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_3_607a00356ff20" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_3_607a00356ff20 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://investchronicle.com/2021/04/16/boiling-and-ready-to-burst-as-ur-energy-inc-urg-last-month-performance-was-16-41/" rel="bookmark" class="td-image-wrap" title="Boiling and ready to burst as Ur-Energy Inc. (URG) last month performance was -16.41%"><img width="218" height="150" class="entry-thumb" src="https://investchronicle.com/wp-content/uploads/2020/01/3-218x150.png" srcset="https://investchronicle.com/wp-content/uploads/2020/01/3-218x150.png 218w, https://investchronicle.com/wp-content/uploads/2020/01/3-100x70.png 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Boiling and ready to burst as Ur-Energy Inc. (URG) last month performance was -16.41%"/></a></div>                <a href="https://investchronicle.com/category/news/" class="td-post-category">News</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://investchronicle.com/2021/04/16/boiling-and-ready-to-burst-as-ur-energy-inc-urg-last-month-performance-was-16-41/" rel="bookmark" title="Boiling and ready to burst as Ur-Energy Inc. (URG) last month performance was -16.41%">Boiling and ready to burst as Ur-Energy Inc. (URG) last month performance was -16.41%</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://investchronicle.com/2021/04/16/social-capital-hedosophia-holdings-corp-vi-ipof-distance-from-20-day-simple-moving-average-is-3-88-what-to-expect/" rel="bookmark" class="td-image-wrap" title="Social Capital Hedosophia Holdings Corp. VI (IPOF) distance from 20-day Simple moving Average is -3.88%: What to Expect?"><img width="218" height="144" class="entry-thumb" src="https://investchronicle.com/wp-content/uploads/2019/06/investchronicle-88-e1579508147511.png" alt="investchronicle 88" title="Social Capital Hedosophia Holdings Corp. VI (IPOF) distance from 20-day Simple moving Average is -3.88%: What to Expect?"/></a></div>                <a href="https://investchronicle.com/category/news/" class="td-post-category">News</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://investchronicle.com/2021/04/16/social-capital-hedosophia-holdings-corp-vi-ipof-distance-from-20-day-simple-moving-average-is-3-88-what-to-expect/" rel="bookmark" title="Social Capital Hedosophia Holdings Corp. VI (IPOF) distance from 20-day Simple moving Average is -3.88%: What to Expect?">Social Capital Hedosophia Holdings Corp. VI (IPOF) distance from 20-day Simple moving Average is -3.88%: What to Expect?</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://investchronicle.com/2021/04/16/time-to-buy-beat-down-toll-brothers-inc-tol-stock-here-is-the-insight-2/" rel="bookmark" class="td-image-wrap" title="Time to Buy Beat-Down Toll Brothers Inc. (TOL) Stock? Here is the INSIGHT"><img width="218" height="150" class="entry-thumb" src="https://investchronicle.com/wp-content/uploads/2020/01/28-218x150.png" srcset="https://investchronicle.com/wp-content/uploads/2020/01/28-218x150.png 218w, https://investchronicle.com/wp-content/uploads/2020/01/28-100x70.png 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Time to Buy Beat-Down Toll Brothers Inc. (TOL) Stock? Here is the INSIGHT"/></a></div>                <a href="https://investchronicle.com/category/news/" class="td-post-category">News</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://investchronicle.com/2021/04/16/time-to-buy-beat-down-toll-brothers-inc-tol-stock-here-is-the-insight-2/" rel="bookmark" title="Time to Buy Beat-Down Toll Brothers Inc. (TOL) Stock? Here is the INSIGHT">Time to Buy Beat-Down Toll Brothers Inc. (TOL) Stock? Here is the INSIGHT</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_607a00356ff20" data-td_block_id="td_uid_3_607a00356ff20"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_3_607a00356ff20" data-td_block_id="td_uid_3_607a00356ff20"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
    	<div class="comments" id="comments">
        	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/04/16/baudax-bio-inc-bxrx-is-on-the-roll-with-an-average-volume-of-5-17m-in-the-recent-3-months/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://investchronicle.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><div class="clearfix"></div>
				<div class="comment-form-input-wrap td-form-comment">
					<textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
					<div class="td-warning-comment">Please enter your comment!</div>
				</div>
		        <div class="comment-form-input-wrap td-form-author">
			            <input class="" id="author" name="author" placeholder="Name:*" type="text" value="" size="30" aria-required='true'/>
			            <div class="td-warning-author">Please enter your name here</div>
			         </div>
<div class="comment-form-input-wrap td-form-email">
			            <input class="" id="email" name="email" placeholder="Email:*" type="text" value="" size="30" aria-required='true'/>
			            <div class="td-warning-email-error">You have entered an incorrect email address!</div>
			            <div class="td-warning-email">Please enter your email address here</div>
			         </div>
<div class="comment-form-input-wrap td-form-url">
			            <input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30"/>
                     </div>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes"/><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment"/> <input type='hidden' name='comment_post_ID' value='159911' id='comment_post_ID'/>
<input type='hidden' name='comment_parent' id='comment_parent' value='0'/>
</p></form>	</div><!-- #respond -->
	    </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <div class="td-a-rec td-a-rec-id-sidebar  td_uid_6_607a003579535_rand td_block_template_11">
<style>.td_uid_6_607a003579535_rand.td-a-rec-img{text-align:left}.td_uid_6_607a003579535_rand.td-a-rec-img img{margin:0 auto 0 0}</style><div id="InvestChronicle_ROS_RightRail_1"></div>
</div><div class="td_block_wrap td_block_9 td_block_widget td_uid_7_607a003579711_rand td-pb-border-top td_block_template_11 td-column-1 td_block_padding td_block_bot_line" data-td-block-uid="td_uid_7_607a003579711"><script>var block_td_uid_7_607a003579711=new tdBlock();block_td_uid_7_607a003579711.id="td_uid_7_607a003579711";block_td_uid_7_607a003579711.atts='{"custom_title":"","custom_url":"","block_template_id":"","header_text_color":"#","border_color":"#","accent_text_color":"#","m8_tl":"","limit":"5","offset":"","el_class":"","post_ids":"","category_id":"","category_ids":"23953, 23954, 23955, 23956","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget td_uid_7_607a003579711_rand","separator":"","show_modified_date":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m8f_title_font_header":"","m8f_title_font_title":"Article title","m8f_title_font_settings":"","m8f_title_font_family":"","m8f_title_font_size":"","m8f_title_font_line_height":"","m8f_title_font_style":"","m8f_title_font_weight":"","m8f_title_font_transform":"","m8f_title_font_spacing":"","m8f_title_":"","m8f_cat_font_title":"Article category tag","m8f_cat_font_settings":"","m8f_cat_font_family":"","m8f_cat_font_size":"","m8f_cat_font_line_height":"","m8f_cat_font_style":"","m8f_cat_font_weight":"","m8f_cat_font_transform":"","m8f_cat_font_spacing":"","m8f_cat_":"","m8f_meta_font_title":"Article meta info","m8f_meta_font_settings":"","m8f_meta_font_family":"","m8f_meta_font_size":"","m8f_meta_font_line_height":"","m8f_meta_font_style":"","m8f_meta_font_weight":"","m8f_meta_font_transform":"","m8f_meta_font_spacing":"","m8f_meta_":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","tdc_css_class":"td_uid_7_607a003579711_rand","tdc_css_class_style":"td_uid_7_607a003579711_rand_style"}';block_td_uid_7_607a003579711.td_column_number="1";block_td_uid_7_607a003579711.block_type="td_block_9";block_td_uid_7_607a003579711.post_count="5";block_td_uid_7_607a003579711.found_posts="110";block_td_uid_7_607a003579711.header_color="";block_td_uid_7_607a003579711.ajax_pagination_infinite_stop="";block_td_uid_7_607a003579711.max_num_pages="22";tdBlocksArray.push(block_td_uid_7_607a003579711);</script><div class="td-block-title-wrap"></div><div id=td_uid_7_607a003579711 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap td-meta-info-hide">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://investchronicle.com/2021/04/14/should-you-buy-or-sell-bentley-systems-bsy/" rel="bookmark" title="Should you Buy or Sell Bentley Systems (BSY)?">Should you Buy or Sell Bentley Systems (BSY)?</a></h3>
                <div class="td-module-meta-info">
                                                                                                </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap td-meta-info-hide">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://investchronicle.com/2021/04/09/duke-energy-duk-stock-is-a-brave-portfolio/" rel="bookmark" title="Duke Energy (DUK) Stock is a Brave Portfolio?">Duke Energy (DUK) Stock is a Brave Portfolio?</a></h3>
                <div class="td-module-meta-info">
                                                                                                </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap td-meta-info-hide">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://investchronicle.com/2021/04/06/be-ready-for-liftoff-for-supernus-pharmaceuticals-inc-supn/" rel="bookmark" title="Be ready for liftoff for Supernus Pharmaceuticals Inc. (SUPN)">Be ready for liftoff for Supernus Pharmaceuticals Inc. (SUPN)</a></h3>
                <div class="td-module-meta-info">
                                                                                                </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap td-meta-info-hide">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://investchronicle.com/2021/03/31/a-little-luck-can-go-a-long-way-with-facebook-inc-fb/" rel="bookmark" title="A Little Luck Can Go a Long Way with Facebook Inc. (FB)">A Little Luck Can Go a Long Way with Facebook Inc. (FB)</a></h3>
                <div class="td-module-meta-info">
                                                                                                </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap td-meta-info-hide">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://investchronicle.com/2021/03/27/is-zoom-a-good-stock-to-buy/" rel="bookmark" title="Is Zoom A Good Stock To Buy? Tech Investment In 2021">Is Zoom A Good Stock To Buy? Tech Investment In 2021</a></h3>
                <div class="td-module-meta-info">
                                                                                                </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block -->
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-custom_ad_1 td_uid_8_607a00357ac4f_rand td_block_template_11 ">

<style>.td_uid_8_607a00357ac4f_rand.td-a-rec-img{text-align:left}.td_uid_8_607a00357ac4f_rand.td-a-rec-img img{margin:0 auto 0 0}</style><script type="text/javascript">var td_screen_width=window.innerWidth;if(td_screen_width>=1140){document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-4244787476385340" data-ad-slot="2370847351"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}if(td_screen_width>=1019&&td_screen_width<1140){document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-4244787476385340" data-ad-slot="2370847351"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}if(td_screen_width>=768&&td_screen_width<1019){document.write('<ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-4244787476385340" data-ad-slot="2370847351"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}if(td_screen_width<768){document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-4244787476385340" data-ad-slot="2370847351"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}</script>
</div>

 <!-- end A --> 

                            </div>
                        </div>
                                    </div> <!-- /.td-pb-row -->
        </div> <!-- /.td-container -->
    </div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->




	<!-- Footer -->
	<div class="td-footer-wrapper td-footer-container td-container-wrap td-footer-template-4 ">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
                		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span12">
                <div class="td-footer-info"><div class="footer-logo-wrap"><a href="https://investchronicle.com/"><img class="td-retina-data" src="https://investchronicle.com/wp-content/uploads/2020/05/Investchronicle-logo-300x74.png" data-retina="https://investchronicle.com/wp-content/uploads/2020/05/Investchronicle-logo-300x74.png" alt="" title="" width=""/></a></div><div class="footer-text-wrap">Investchronicle.com is an Economic news website, which offers broad information about the Stock markets and Equities. The major emphasis of this platform is to present, the most practical recommendation for public and private capital sharing, both in the form of updates and detailed analysis.<div class="footer-email-wrap">Contact us: <a href="mailto:editor@Investchronicle.com">editor@Investchronicle.com</a></div></div><div class="footer-social-wrap td-social-style-2"></div></div><aside class="widget_text td_block_template_11 widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="InvestChronicle_ROS_Top_Leaderboard"></div>
</div></aside>            </div>
        </div>
    </div>
</div>
	<!-- Sub Footer -->
	    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                    <div class="menu-footor-container"><ul id="menu-footor" class="td-subfooter-menu"><li id="menu-item-62490" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-62490"><a href="https://investchronicle.com/about-us/">About us</a></li>
<li id="menu-item-62488" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-62488"><a href="https://investchronicle.com/core-team/">Core Team</a></li>
<li id="menu-item-62487" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-62487"><a href="https://investchronicle.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-62489" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-62489"><a href="https://investchronicle.com/contact/">Contact</a></li>
</ul></div>                </div>

                <div class="td-pb-span td-sub-footer-copy">
                    &copy; Copyright 2019 - Investchronicle                 </div>
            </div>
        </div>
    </div>


</div><!--close td-outer-wrap-->


<!-- Snippets by Add to All -->			<div class="cpro-onload  cp-popup-global  cp-custom-cls-manual_trigger_126461 " data-class-id="126461" data-inactive-time='60'></div>
			
		<div id="cp_popup_id_126461" class="cp-popup-container cp-popup-live-wrap cp_style_126461 cp-module-modal_popup  " data-style="cp_style_126461" data-module-type="modal_popup" data-class-id="126461" data-styleslug="co-reg">

							<div class="cpro-overlay">
			
			<div class="cp-popup-wrapper cp-auto  ">
				<div class="cp-popup  cpro-animate-container ">

					
								<form class="cpro-form" method="post">
						<input type='hidden' class='panel-settings' data-style_id='126461' data-section='configure' value='{&quot;enable_custom_cookies&quot;:&quot;&quot;,&quot;enable_cookies_class&quot;:&quot;&quot;,&quot;enable_adblock_detection&quot;:&quot;&quot;,&quot;enable_visitors&quot;:&quot;&quot;,&quot;visitor_type&quot;:&quot;first-time&quot;,&quot;referrer_type&quot;:&quot;hide-from&quot;,&quot;hide_custom_cookies&quot;:&quot;&quot;,&quot;hide_cookies_class&quot;:&quot;&quot;,&quot;show_for_logged_in&quot;:&quot;1&quot;,&quot;hide_on_device&quot;:&quot;&quot;,&quot;cookies_enabled&quot;:&quot;1&quot;,&quot;conversion_cookie&quot;:&quot;90&quot;,&quot;closed_cookie&quot;:&quot;30&quot;,&quot;cookies_enabled_submit&quot;:&quot;&quot;,&quot;enable_cookies_class_submit&quot;:&quot;&quot;,&quot;conversion_cookie_submit&quot;:&quot;90&quot;,&quot;cookies_enabled_closed&quot;:&quot;&quot;,&quot;enable_cookies_class_closed&quot;:&quot;&quot;,&quot;closed_cookie_new&quot;:&quot;30&quot;}'><input type='hidden' class='panel-rulesets' data-style_id='126461' data-section='configure' value='[{&quot;name&quot;:&quot;Ruleset 1&quot;,&quot;autoload_on_duration&quot;:true,&quot;load_on_duration&quot;:&quot;5&quot;,&quot;modal_exit_intent&quot;:&quot;1&quot;,&quot;autoload_on_scroll&quot;:false,&quot;load_after_scroll&quot;:75,&quot;inactivity&quot;:false,&quot;inactivity_link&quot;:&quot;&quot;,&quot;enable_after_post&quot;:false,&quot;enable_custom_scroll&quot;:false,&quot;enable_scroll_class&quot;:&quot;&quot;,&quot;on_scroll_txt&quot;:&quot;&quot;,&quot;show_cta_info&quot;:&quot;&quot;,&quot;enable_custom_cookies&quot;:false,&quot;enable_cookies_class&quot;:&quot;&quot;,&quot;on_cookie_txt&quot;:&quot;&quot;,&quot;hide_cta_link&quot;:&quot;&quot;,&quot;enable_adblock_detection&quot;:false,&quot;all_visitor_info&quot;:&quot;&quot;,&quot;enable_visitors&quot;:&quot;&quot;,&quot;visitor_type&quot;:&quot;first-time&quot;,&quot;enable_referrer&quot;:&quot;&quot;,&quot;referrer_type&quot;:&quot;hide-from&quot;,&quot;display_to&quot;:&quot;&quot;,&quot;hide_from&quot;:&quot;&quot;,&quot;enable_scheduler&quot;:false,&quot;enable_scheduler_txt&quot;:&quot;&quot;,&quot;start_date&quot;:&quot;&quot;,&quot;end_date&quot;:&quot;&quot;,&quot;custom_cls_text_head&quot;:&quot;&quot;,&quot;enable_custom_class&quot;:&quot;1&quot;,&quot;copy_link_code_button&quot;:&quot;Copy Link Code&quot;,&quot;copy_link_cls_code_button&quot;:&quot;&quot;,&quot;custom_class&quot;:&quot;&quot;,&quot;custom_cls_text&quot;:&quot;&quot;}]'><style id='cp_popup_style_126461' type='text/css'>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</style>
					<div class="cp-popup-content cpro-active-step  cp-modal_popup      cp-panel-1" data-entry-animation="cp-fadeIn" data-overlay-click="1" data-title="Co Reg" data-module-type="modal_popup" data-step="1" data-width="800" data-mobile-width="320" data-height="500" data-mobile-height="200" data-mobile-break-pt="767" data-mobile-responsive="yes">
												
					<div class="cpro-form-container">                             
						<div id="cp_close_image-0-126461" class="cp-field-html-data    cp-none cp-image-ratio cp-close-field cp-close-image-wrap" data-type="cp_close_image" data-field-title="Close Image" data-action="close">	
	<div class="cp-rotate-wrap">
		<div class="cp-image-main"><img data-cp-src="https://investchronicle.com/wp-content/plugins/convertpro/assets/admin/img/close1.png" class="cp-target cp-field-element cp-close-image cp-img-lazy" alt="" name="cp_close_image-0" value="" src="">
			<div class="cp-field-shadow"></div>
		</div>
		
	</div>
</div><div id="cp_heading-0-126461" class="cp-field-html-data    cp-none cp_has_editor" data-type="cp_heading"><div class="cp-rotate-wrap"><div class="cp-target cp-field-element cp-heading tinymce" name="cp_heading-0"><p>Get The Best Stocks To Trade Every Day!</p></div></div>
</div><div id="cp_sub_heading-0-126461" class="cp-field-html-data    cp-none cp_has_editor" data-type="cp_sub_heading" data-field-title="Subheading"><div class="cp-rotate-wrap"><div class="cp-target cp-field-element cp-sub-heading tinymce" name="{{name}}"><p>Join now to get the Newsheater.com pre-market morning brief 100% free</p></div></div>
</div><div id="cp_email-0-126461" class="cp-field-html-data    cp-none" data-type="cp_email">
	<input type="email" class="cp-target cp-field-element cp-form-input-field cp-form-field cp-email cp-form-field cp-email-field" aria-label="Enter your email here" placeholder="Enter your email here" name="param[email]" value="" required="required" data-email-error-msg="{{email-error}}" autocomplete="on"/>
</div><div id="cp_button-0-126461" class="cp-field-html-data   cp-none" data-type="cp_button" data-action="submit_n_goto_url" data-step="1" data-redirect="https://offers.afteroffers.com/show_offers/774-HDQBDDH-1" data-redirect-target="_self">
	<div class="cp-rotate-wrap"><button type="submit" class=" cp-target cp-field-element cp-button cp-button-field" data-success-message="Thank You for Subscribing!" data-get-param="true">Yes, Sign Me Up!</button>
	<div class="cp-btn-tooltip"></div>
</div></div><div id="cp_paragraph-0-126461" class="cp-field-html-data    cp-none cp_has_editor" data-type="cp_paragraph" data-field-title="Paragraph"><div class="cp-rotate-wrap"><div class="cp-target cp-field-element cp-paragraph tinymce" name="{{name}}"><p>We do not sell or share your information with anyone.</p></div></div>
</div><div id="cp_google_recaptcha-0-126461" class="cp-field-html-data    {{animation}} cp-hidden-input-field cp-google-recaptcha-field" data-type="cp_google_recaptcha" data-field-title="Recaptcha">
	
	<input type="hidden" class="cp-target cp-field-element cp-form-field cp-google-recaptcha " name="cp_google_recaptcha_verify" value="6Lc5p-wZAAAAAJDdPAG-8R4QTlVWp65YdWiaspSF" placeholder="recaptcha field"/>
	
	<span class="recaptcha-msg-error error"></span>
	<div class="g-recaptcha" data-sitekey="6Lc5p-wZAAAAAJDdPAG-8R4QTlVWp65YdWiaspSF"></div>
</div>							</div>              
														
						</div><!-- .cp-popup-content -->
						      
		<input type="hidden" name="param[date]" value="April 16, 2021"/>
		<input type='text' class='cpro-hp-field' name='cpro_hp_field_126461' value=''>
		<input type="hidden" name="action" value="cp_v2_add_subscriber"/>
		<input type="hidden" name="style_id" value="126461"/>
						</form>
										</div>
							</div><!-- .cp-popup-wrapper -->
			
							</div><!-- Overlay -->
				

					</div><!-- Modal popup container -->
			

    <!--

        Theme: Newspaper by tagDiv.com 2019
        Version: 9.7.3 (rara)
        Deploy mode: deploy
        
        uid: 607a00357cb45
    -->

    <script type="text/javascript">jQuery().ready(function(){if(typeof tdsDateFormat!=='undefined'){var tdBusinessDateTimestamp=Math.floor(new Date().getTime()/1000);var tdBusinessTodayDate=td_date_i18n(tdsDateFormat,tdBusinessDateTimestamp);jQuery('.td-business-demo-js-date-today').text(tdBusinessTodayDate);}});</script><link rel='stylesheet' id='cp-google-fonts-126461-css' href='//fonts.googleapis.com/css?family=Merriweather+Sans%3A700%2CNormal%2C700%2C&#038;ver=1.5.7' type='text/css' media='all'/>
<script type='text/javascript' src='https://investchronicle.com/wp-includes/js/underscore.min.js?ver=1.8.3' id='underscore-js'></script>
<script type='text/javascript' src='https://investchronicle.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=d158fac1e2f85794ec26781eb2a38fd9' id='tdb_js_posts_autoload-js'></script>
<script type='text/javascript' src='https://investchronicle.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=9.7.3' id='td-site-min-js'></script>
<script type='text/javascript' src='https://investchronicle.com/wp-includes/js/comment-reply.min.js?ver=5.7.1' id='comment-reply-js'></script>
<script type='text/javascript' src='https://investchronicle.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=d158fac1e2f85794ec26781eb2a38fd9' id='tdb_js_files_for_front-js'></script>
<script type='text/javascript' src='https://investchronicle.com/wp-includes/js/wp-embed.min.js?ver=5.7.1' id='wp-embed-js'></script>
<script type='text/javascript' id='cp-popup-script-js-extra'>//<![CDATA[
var cp_ajax={"url":"https:\/\/investchronicle.com\/wp-admin\/admin-ajax.php","ajax_nonce":"713ef4fb6f","assets_url":"https:\/\/investchronicle.com\/wp-content\/plugins\/convertpro\/assets\/","not_connected_to_mailer":"This form is not connected with any mailer service! Please contact web administrator.","timer_labels":"Years,Months,Weeks,Days,Hours,Minutes,Seconds","timer_labels_singular":"Year,Month,Week,Day,Hour,Minute,Second","image_on_ready":"","cpro_mx_valid":"1","invalid_email_id":"Invalid Email Address!"};var cp_pro={"inactive_time":"60"};var cp_pro_url_cookie={"days":"30"};var cp_ga_object={"ga_auth_type":"manual","ga_category_name":"Convert Pro","ga_event_name":"CONVERTPRO","ga_anonymous_ip":"checked"};var cp_v2_ab_tests={"cp_v2_ab_tests_object":[]};
//]]></script>
<script type='text/javascript' defer="defer" src='https://investchronicle.com/wp-content/plugins/convertpro/assets/modules/js/cp-popup.min.js?ver=1.5.7' id='cp-popup-script-js'></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?ver=1.5.7' id='cp-google-recaptcha-js'></script>
	
			<script type="text/javascript">jQuery(document).on("cp_after_form_submit",function(e,element,response,style_slug){if(false==response.data.error){if('undefined'!==typeof response.data['cfox_data']){var form_data=JSON.parse(response.data['cfox_data']);form_data.overwrite_tags=false;if('undefined'!==typeof convertfox){convertfox.identify(form_data);}}}});</script>
				<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-142868351-1"></script>
<script>window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments);}gtag('js',new Date());gtag('config','UA-142868351-1');</script>
				<!-- This is minified version of cp-ga-front.js file located at convertpro-addon/analytics/assets/js/cp-ga-front.js if you want to make changes to this, edit cp-ga-front.js file, minify it and paste code here -->

				<script type="text/javascript">!function(e){var t="";e(window).on("cp_after_popup_open",function(e,t,n,o){var a=jQuery('.cp-popup-container[data-style="cp_style_'+o+'"]').data("styleslug");cpUpdateImpressions(a)}),cpUpdateImpressions=function(e){var t=cp_ga_object.ga_category_name;cpCreateGoogleAnalyticEvent(t,"impression",e)},cpIsModuleOnScreen=function(e){var t=jQuery(window),n={top:t.scrollTop(),left:t.scrollLeft()};n.right=n.left+t.width(),n.bottom=n.top+t.height();var o=e.offset();return o.right=o.left+e.outerWidth(),o.bottom=o.top+e.outerHeight(),!(n.right<o.left||n.left>o.right||n.bottom<o.top||n.top>o.bottom)},e(document).on("cp_after_form_submit",function(e,t,n,o){if(!0===n.success){var a=cp_ga_object.ga_category_name;cpCreateGoogleAnalyticEvent(a,"conversion",o)}}),cpCreateGoogleAnalyticEvent=function(e,n,o){void 0!==t&&("undefined"!=typeof ga?t=ga:"undefined"!=typeof _gaq?t=_gaq:"function"==typeof __gaTracker?t=__gaTracker:"function"==typeof gaplusu&&(t=gaplusu));var a=void 0!==cp_ga_object.ga_auth_type?cp_ga_object.ga_auth_type:"universal-ga";"undefined"!=typeof dataLayer&&"gtm-code"==a?dataLayer.push({event:cp_ga_object.ga_event_name,eventCategory:e,eventAction:n,eventLabel:o,eventValue:"1",nonInteraction:!0}):"gtag"==a&&"undefined"!=typeof gtag?"unchecked"!=cp_ga_object.ga_anonymous_ip?gtag("event",n,{event_label:o,event_category:e,non_interaction:!0,anonymize_ip:!0}):gtag("event",n,{event_label:o,event_category:e,non_interaction:!0}):"universal-ga"!=a&&"manual"!=a||"function"!=typeof t||("unchecked"!=cp_ga_object.ga_anonymous_ip?t("send","event",e,n,o,{nonInteraction:!0,anonymizeIp:!0}):t("send","event",e,n,o,{nonInteraction:!0}))},cp_track_inline_modules=function(){jQuery(".cp-popup-container.cp-module-before_after, .cp-popup-container.cp-module-inline, .cp-popup-container.cp-module-widget").each(function(){var e=jQuery(this);e.data("style").replace("cp_style_","");if(cpIsModuleOnScreen(e)&&!e.hasClass("cp-impression-counted")){var t=e.data("styleslug");cpUpdateImpressions(t),e.addClass("cp-impression-counted")}})},e(document).ready(function(){cp_track_inline_modules()}),e(document).on('scroll',function(e){cp_track_inline_modules()})}(jQuery);</script>
				
<!-- JS generated by theme -->

<script></script>


</body>
</html>